Page MenuHomePhabricator

Special:SpamRegex is not accessible by administrators
Closed, InvalidPublic

Description

Attempting to access Special:SpamRegex results in the message

You do not have permission to block spam phrases, for the following reason:
The action you have requested is limited to users in the group: Staff.

Restriction to Staff may be by design, but it would be worth allowing at least administrators to see the regexes, at least to avoid conflicts with AbuseFilter.

Saftzie created this task.Dec 16 2016, 10:37 PM
lewiscawte assigned this task to jack.Dec 16 2016, 11:17 PM
lewiscawte triaged this task as Normal priority.
lewiscawte added a subscriber: lewiscawte.

Fair point, assigning to Jack who is far more knowledgeable on this particular extension for input.

jack closed this task as Resolved.Dec 17 2016, 5:26 PM

Long story short, SpamRegex is intentionally very restricted because unlike AbuseFilter and whatnot, it is a global tool. If it were administrator-viewable (let alone editable!), that probably wouldn't go so well because all you need is a valid email address to create a new wiki.

Hub is a bit of a special case, as all Hub admins are directly appointed by staff, and thus are known to be trustworthy users. As such, we've decided to grant the spamregex user right to Hub admins only (in addition to staff).

Phabricator changed the task status from Resolved to Invalid.Apr 22 2018, 5:54 PM