Page MenuHomePhabricator

Use VIPS for image scaling & deploy the VipsScaler MediaWiki extension
Closed, ResolvedPublic

Description

Quoth MediaWiki.org info page for the VipsScaler extension: "The VipsScaler extension is a wrapper around VIPS, a free image processing software. VIPS is a set of image manipulation tools specially designed for speed and low memory usage. This is useful for resizing large PNGs, and it improves the appearance of shrunken JPEGs."

Event Timeline

jack created this task.Feb 27 2017, 3:23 AM
lewiscawte moved this task from Extensions to Servers on the 2017 Major Operations board.

Currently being used on Brickipedia with no issues. Hope to roll out globally soon.

@gbarnick So Bricki is the one wiki currently testing VipsSscaler - might be the cause of your image thumbnail problems? Can you provide a few examples and make sure to note which part is wrong/what it should be?

Sounds like it could be a possibility.

Here's some info. I've only uploaded one file to test so far, but it's http://en.brickimedia.org/wiki/File:ToaMeiko_Avatar.png

As you can see in this screenshot, the non-thumbnailed full-size photo up top is correct, but in the version history where it's thumbnailed it still shows the old revision.

Targetting global deployment Q1 2019 using settings currently running at Brickipedia.

lewiscawte moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.Feb 25 2019, 2:23 AM

Deployed - testing for a few days before cleaning up Brickipedia and closing as resolved.

lewiscawte closed this task as Resolved.Jul 25 2019, 11:44 AM

Been deployed for a number of months now with no issues.